Cannot Start Playing, No Tracks Setup.

Topics: Question
Oct 24, 2016 at 1:52 PM
Hi,

First of all fantastic work on this in-depth code base. It looks like it is a one stop shop for simple integration.

I am currently attempting to utilise the RTSPClient class in order to acquire frames from an RTSP stream generated by a suppliers device. I have managed to connect to the device and acquire elementary request response packets as indicated by other discussions in the forum. I am very new to network streaming techniques so my knowledge is fairly incomplete despite reading around the topic.

If needed I can post my whole code but I believe the pertinent point is that when I attempt to call the Play function in the client I get the following error:

response-------------------
RTSP/1.0 461 UnsupportedTransport

and in Visual studio I receive the error:

An exception of type 'System.InvalidOperationException' occurred in Media.Rtsp.dll but was not handled in user code

Additional information: Cannot Start Playing, No Tracks Setup.


The full description response is as follows:

request-------------------
DESCRIBE rtsp://192.168.0.120/stream.sdp RTSP/1.0
Accept: application/sdp
CSeq: 2


response-------------------
RTSP/1.0 200 OK
CSeq: 2
Content-Type: application/sdp
Content-Length: 223

v=0
o=- 127621771 1 IN IP4 192.168.0.120
s=Video session
i=NNV
t=0 0
a=type:broadcast
m=video 10334 RTP/AVP 33
a=range:npt=0-
a=rtpmap:33 MP2T/90000
a=control:rtsp://192.168.0.120/stream.sdp
c=IN IP4 0 0 0 0



I'm not sure if I have it set up correct but I have attempted to insert the information received from the device in the DESCRIBE packet in a MediaDescription pass to Play but this yields the same result.

Any help would be appreciated.

Many thanks in advanced

SI